Support & Community Forum
Get answers from our staff and other members of the XSplit community!

Xsplit doesn't pick up Cutscene audio

(All non-version 1 threads must be posted here)
Forum rules 1. Please check the Forum Guidelines first before posting. Threads that do not comply with our guidelines will not be replied to by the staff.
2. Consult the FAQ.
3. Always post your hardware and internet specs before you post.

Xsplit doesn't pick up Cutscene audio

by Neomeo » Tue Jan 31, 2012 10:54 am

Following problem, whenever I play a game and it comes to a cutscene, the audio won't get broadcasted. All the other sound like Skype, in game music, general in game sound, are working just fine! Only the spoken part during the cutscene is missing. I can hear it on my end, but not on stream.

Is there a way to fix this?
Neomeo
XSplit User
Posts: 13
Joined: Thu Nov 24, 2011 1:34 pm
Location: Switzerland
RAM: 8 GB
Graphics Card: Nvidia GTX 570
Operating System: 64 Bit Win 7

Re: Xsplit doesn't pick up Cutscene audio

by HellGreen » Tue Jan 31, 2012 1:16 pm

Sounds a like a game related issue. What is your game?
Can you provide a VOD example?
Is the source that should play the cutscene audio selected as the default playback device in Windows? It must be, though I don't see how the game would use different sources.
For the latest guides and beta versions (and occasional contents to win XSplit) follow us on our social media.
Image Like us on Facebook Image Follow us on Twitter
HellGreen
Support Boss
Posts: 3887
Joined: Wed Sep 14, 2011 2:31 am
Location: Manila, Philippines
CPU: Intel i7 3770k
RAM: 16GB
Graphics Card: ATI HD7850
Operating System: Win 7 x64
Internet Connection: >9000 bps

Re: Xsplit doesn't pick up Cutscene audio

by Neomeo » Tue Jan 31, 2012 2:24 pm

I tried it with Saints Row the third and L.A. Noire both have the same issue.
This would be the video: http://www.youtube.com/watch?v=B6JZyD5kxBc&t=1m10s
All other sounds are fine just the Voice is missing.
And yes the source is setup correct.
Neomeo
XSplit User
Posts: 13
Joined: Thu Nov 24, 2011 1:34 pm
Location: Switzerland
RAM: 8 GB
Graphics Card: Nvidia GTX 570
Operating System: 64 Bit Win 7

Re: Xsplit doesn't pick up Cutscene audio

by Katabasis » Tue Jan 31, 2012 6:54 pm

You have to turn off certain channels of audio. Kinda confusing and hard to explain. If you come by my channel tonight after 8 pm PST I will show you while I stream. Www.twitch.tv/Katabasis
Katabasis
XSplit User
Posts: 75
Joined: Sat Dec 03, 2011 11:43 pm

Re: Xsplit doesn't pick up Cutscene audio

by Neomeo » Tue Jan 31, 2012 7:44 pm

That'll be great! Thanks a lot for responding!
Neomeo
XSplit User
Posts: 13
Joined: Thu Nov 24, 2011 1:34 pm
Location: Switzerland
RAM: 8 GB
Graphics Card: Nvidia GTX 570
Operating System: 64 Bit Win 7

Re: Xsplit doesn't pick up Cutscene audio

by Katabasis » Tue Jan 31, 2012 10:21 pm

Ya np! If you come in and I don't notice your chat tell a mod to get my attention that I told you I would help on the forums. Should notice but since I play dead is dead and chat gets crazy sometimes I miss and I don't want to not help you
Katabasis
XSplit User
Posts: 75
Joined: Sat Dec 03, 2011 11:43 pm

Re: Xsplit doesn't pick up Cutscene audio

by Katabasis » Wed Feb 01, 2012 6:50 pm

Did my advice help at all?
Katabasis
XSplit User
Posts: 75
Joined: Sat Dec 03, 2011 11:43 pm

Re: Xsplit doesn't pick up Cutscene audio

by Neomeo » Wed Feb 01, 2012 11:40 pm

Yes! thanks a lot for you help, I really appreciate it! :)
Neomeo
XSplit User
Posts: 13
Joined: Thu Nov 24, 2011 1:34 pm
Location: Switzerland
RAM: 8 GB
Graphics Card: Nvidia GTX 570
Operating System: 64 Bit Win 7

Re: Xsplit doesn't pick up Cutscene audio

by HellGreen » Thu Feb 02, 2012 12:53 am

Any chance for a written answer for others to use? :D
For the latest guides and beta versions (and occasional contents to win XSplit) follow us on our social media.
Image Like us on Facebook Image Follow us on Twitter
HellGreen
Support Boss
Posts: 3887
Joined: Wed Sep 14, 2011 2:31 am
Location: Manila, Philippines
CPU: Intel i7 3770k
RAM: 16GB
Graphics Card: ATI HD7850
Operating System: Win 7 x64
Internet Connection: >9000 bps

Re: Xsplit doesn't pick up Cutscene audio

by Katabasis » Thu Feb 02, 2012 1:04 am

I'll try but it may not be the best. Btw I'm pretty sure this will become more of a common problem as more people move to USB mic/headsets and those with onboard sound cards only.

Go to playback devices
Go to your main sound device. For me it's speakers (logitech g930)
Right click and select configure speakers...
Click on each of the speaker icons and ask if anyone hears the dinging.
In my system I have to turn off center speaker, both sides and both rear.
To do this click Test.
To turn off the channels that do not function in your stream click Next and uncheck the boxes.
Click Next again and click off any more.
Click next and finish.

NOTE. If you do this you have to restart whatever applications you need sound before it will take effect. Such as Firefox for YouTube, the game, xsplit, pandora etc.

The reason this happens is USB headsets are notoriously buggy with streaming software. Add in no stereo mix channel for those of us that lack it means xsplit will not register the pimp headset as a 7.1 device. The game does however and sends most cutscenes audio directly down the center channel....which doesn't work. Xsplit only sees typically left and right channels with USB headsets without stereo mix.


Whew hope that helps!
Katabasis
XSplit User
Posts: 75
Joined: Sat Dec 03, 2011 11:43 pm

Re: Xsplit doesn't pick up Cutscene audio

by vampy84 » Wed May 09, 2012 10:08 pm

Katabasis wrote:I'll try but it may not be the best.


Thank you so much for the details!
Wasted numerous hours of footage due to the bug as well as countless hours in desperate attempts on finding the source/cause/fix for the problem.

Thank you once again :)



hellgreen wrote:Any chance for a written answer for others to use? :D


any ETAs on a fix? Seems that Xsplit only picks up 2 out of 7.1 on the g930 headset. :cry:
vampy84
XSplit User
Posts: 3
Joined: Sat Mar 31, 2012 3:48 pm

Re: Xsplit doesn't pick up Cutscene audio

by HellGreen » Thu May 10, 2012 12:00 pm

Hang on, let me ask around what we actually support in terms of audio channels.
For the latest guides and beta versions (and occasional contents to win XSplit) follow us on our social media.
Image Like us on Facebook Image Follow us on Twitter
HellGreen
Support Boss
Posts: 3887
Joined: Wed Sep 14, 2011 2:31 am
Location: Manila, Philippines
CPU: Intel i7 3770k
RAM: 16GB
Graphics Card: ATI HD7850
Operating System: Win 7 x64
Internet Connection: >9000 bps

Re: Xsplit doesn't pick up Cutscene audio

by CDriVe1335 » Mon May 14, 2012 5:38 pm

Id still appreciate a reply from Hellgreen about what audio channels Xsplit supports. I'm currently running into an issue myself where 6 channel audio is being picked up, but 8 channel audio is missing voice overs. If there is a way to fix this please let us know!
CDriVe1335
XSplit User
Posts: 6
Joined: Thu May 10, 2012 10:39 pm
CPU: i5-2500K @ 4.4 GHZ
RAM: 8 Gigs DDR3 1600
Graphics Card: GTX 560ti @ 925 MHz
Operating System: Windows 7 64bit
Internet Connection: 32 Mbps Down / 7 Mbps Up

Re: Xsplit doesn't pick up Cutscene audio

by HellGreen » Tue May 15, 2012 5:38 am

I will post an answer when I got one from the audio engineers. No need for bumps please.
For the latest guides and beta versions (and occasional contents to win XSplit) follow us on our social media.
Image Like us on Facebook Image Follow us on Twitter
HellGreen
Support Boss
Posts: 3887
Joined: Wed Sep 14, 2011 2:31 am
Location: Manila, Philippines
CPU: Intel i7 3770k
RAM: 16GB
Graphics Card: ATI HD7850
Operating System: Win 7 x64
Internet Connection: >9000 bps