Support & Community Forum
Get answers from our staff and other members of the XSplit community!

Streaming headphone sound

(All non-version 1 threads must be posted here)
Forum rules 1. Please check the Forum Guidelines first before posting. Threads that do not comply with our guidelines will not be replied to by the staff.
2. Consult the FAQ.
3. Always post your hardware and internet specs before you post.

Streaming headphone sound

by Cirno9 » Thu Apr 05, 2012 2:59 pm

I made a topic on this half a year ago , and while I got some suggestions and help, none of it actually fixed the problem.

I normally play with sound coming through my speakers, and xsplit captures that just fine, however some games (horror) I want to play with my headphones on, as it increases the tense mood greatly.

I'm using Logitech G35 surround sound headphones, which I've tried with old and new drivers. Speakers are just the my monitor speakers.

So...
When I change my playback device to my headphones though, people watching can no longer hear the game sounds. How do I get xsplit to capture the sound in my headphones?
Cirno9
XSplit User
Posts: 20
Joined: Wed Aug 24, 2011 9:38 pm
CPU: i5 2500k
RAM: 8GB
Graphics Card: 6950*2
Operating System: Win7 64bit
Capture Card: Happauge
Internet Connection: 50/10Mbps

Re: Streaming headphone sound

by Cirno9 » Tue Apr 10, 2012 9:44 pm

Bump for having this issue for months with no support >:
Cirno9
XSplit User
Posts: 20
Joined: Wed Aug 24, 2011 9:38 pm
CPU: i5 2500k
RAM: 8GB
Graphics Card: 6950*2
Operating System: Win7 64bit
Capture Card: Happauge
Internet Connection: 50/10Mbps

Re: Streaming headphone sound

by cH053n » Tue Apr 10, 2012 10:53 pm

Uhm xsplit should capture audio from your default playback device.

Soo... you sure you set the headphones as the default device?

here is a tutorial - http://www.7tutorials.com/how-change-de ... dio-device
If you appreciate my help then please return the favor by rating the quality of my stream. Thanks! viewtopic.php?f=2&t=7764
cH053n
XSplit User
Posts: 16
Joined: Wed Dec 07, 2011 11:51 am
Location: Houston, Tx
CPU: core I7 950 @4.0Ghz
RAM: 6GB DDR3 @1600
Graphics Card: ATI Radeon HD 5870 Crossfire @850/1200
Operating System: Windows 7 64-bit
Internet Connection: DSL 6mbps/.65mbps

Re: Streaming headphone sound

by ViciousXUSMC » Wed Apr 11, 2012 5:11 am

I imagine it has to do with the complex drivers and virtual surround those headphones use causing a problem for xsplit to pick it up.

One thing to do that will probably work is not use the logitech drivers and instead use generic usb audio drivers but then you lose all your fancy logitech software support and you will find they sound like crap without the artificial enhancements.
ViciousXUSMC
XSplit User
Posts: 86
Joined: Sat Jan 21, 2012 5:44 pm

Re: Streaming headphone sound

by Cirno9 » Sun Aug 12, 2012 10:52 pm

cH053n wrote:Uhm xsplit should capture audio from your default playback device.

Soo... you sure you set the headphones as the default device?

here is a tutorial - http://www.7tutorials.com/how-change-de ... dio-device


:| Ya, I'm pretty sure.


I'm still looking for an answer if anyone has one.
Cirno9
XSplit User
Posts: 20
Joined: Wed Aug 24, 2011 9:38 pm
CPU: i5 2500k
RAM: 8GB
Graphics Card: 6950*2
Operating System: Win7 64bit
Capture Card: Happauge
Internet Connection: 50/10Mbps